Skip to content

OS/2 Warp 4

I just recently acquired a copy of OS/2 Warp 4, among other things, from a friend. I’ve been working on getting it installed on an old AMD K6 system that I have laying about.

After replacing a bad PSU, I found that the hard drive (just barely over 4 gigabytes) was too large for the stock OS/2 disks.

The solution took some digging, because of the age of OS/2 and the lack of support from IBM. Most IBM pages on OS/2 have been redirected to a end of support notice. Long story short:

  1. Download ibmide.zip from the Hobbes OS/2 Archive.
  2. Replace IBM1S506.ADD on Diskette 1, which is, confusingly enough, the second disk of the installation procedure.
  3. Edit the config.sys file on Diskette 1, so that the first line of the file is SET COPYFROMFLOPPY=1

More details:

IBM1S506.ADD is the device driver for IDE drives. IBMDASD.EXE (DASD is IBM speak for hard drives) is referenced in several places as the current update, but I could not find it.  The file from ibmide.zip is current enough for this effort.

Diskette 1, as referenced above, is actually the second disk of the OS/2 installation series. With my copy, there is an “Installation Diskette”, and a Diskette 1 and 2. One boots off the Installation Diskette.

Setting COPYFROMFLOPPY in config.sys causes the installer to copy files, like IBM1S506.ADD, from the floppy disks, rather than from the CD which has the old version. I would assume that if you had a floppy version of the OS/2 install set, you wouldn’t need this flag, but I do not know.